Getting started: PySnip/pyspades server software

Host your own server and communicate with server operators.
65 posts Page 2 of 5
Nuvolkinton
Deuce
Posts: 2
Joined: Sat Apr 13, 2013 12:22 pm


Hello, I get the following error when trying to get into my server: server connection failed.

I downloaded the following application for windows: https://code.google.com/p/pysnip/downlo ... p&can=2&q=

To give you more information, to comment that I have opened UDP port 32887 and I have configured the firewall to not block the following applications: RUN.EXE and Ace of Spades Server.

Then I copied the log that I get to create the server:

2013-04-13 14:24:09+0200 [-] pyspades server started on 04/13/13 14:24:09
2013-04-13 14:24:09+0200 [-] Log opened.
2013-04-13 14:24:09+0200 [-] Generating map 'classicgen #1912365974'...
2013-04-13 14:24:14+0200 [-] Map loaded successfully.
2013-04-13 14:24:14+0200 [-] Starting factory <HTTPClientFactory: http://services.buildandshoot.com/getip>
2013-04-13 14:24:14+0200 [-] Started server...
2013-04-13 14:24:14+0200 [-] Master connection established.
2013-04-13 14:24:15+0200 [HTTPPageGetter,client] Server identifier is aos://3679621455:32887
2013-04-13 14:24:15+0200 [HTTPPageGetter,client] Stopping factory <HTTPClientFactory: http://services.buildandshoot.com/getip>
2013-04-13 14:24:17+0200 [HTTPPageGetter,client] Stopping factory <HTTPClientFactory: http://www.blacklist.spadille.net/subsc ... ormat=json>

Thank you.
BlueBird
Blue Master Race
Blue Master Race
Posts: 27
Joined: Sat Mar 16, 2013 11:41 am


Nuvolkinton wrote:
Hello, I get the following error when trying to get into my server: server connection failed.

I downloaded the following application for windows: https://code.google.com/p/pysnip/downlo ... p&can=2&q=

To give you more information, to comment that I have opened UDP port 32887 and I have configured the firewall to not block the following applications: RUN.EXE and Ace of Spades Server.

Then I copied the log that I get to create the server:

2013-04-13 14:24:09+0200 [-] pyspades server started on 04/13/13 14:24:09
2013-04-13 14:24:09+0200 [-] Log opened.
2013-04-13 14:24:09+0200 [-] Generating map 'classicgen #1912365974'...
2013-04-13 14:24:14+0200 [-] Map loaded successfully.
2013-04-13 14:24:14+0200 [-] Starting factory <HTTPClientFactory: http://services.buildandshoot.com/getip>
2013-04-13 14:24:14+0200 [-] Started server...
2013-04-13 14:24:14+0200 [-] Master connection established.
2013-04-13 14:24:15+0200 [HTTPPageGetter,client] Server identifier is aos://3679621455:32887
2013-04-13 14:24:15+0200 [HTTPPageGetter,client] Stopping factory <HTTPClientFactory: http://services.buildandshoot.com/getip>
2013-04-13 14:24:17+0200 [HTTPPageGetter,client] Stopping factory <HTTPClientFactory: http://www.blacklist.spadille.net/subsc ... ormat=json>

Thank you.
Same ^^
[RUS] Vlad01
League Participant
League Participant
Posts: 1610
Joined: Sun Dec 16, 2012 7:37 am


Nuvolkinton wrote:
Hello, I get the following error when trying to get into my server: server connection failed.

I downloaded the following application for windows: https://code.google.com/p/pysnip/downlo ... p&can=2&q=

To give you more information, to comment that I have opened UDP port 32887 and I have configured the firewall to not block the following applications: RUN.EXE and Ace of Spades Server.

Then I copied the log that I get to create the server:

2013-04-13 14:24:09+0200 [-] pyspades server started on 04/13/13 14:24:09
2013-04-13 14:24:09+0200 [-] Log opened.
2013-04-13 14:24:09+0200 [-] Generating map 'classicgen #1912365974'...
2013-04-13 14:24:14+0200 [-] Map loaded successfully.
2013-04-13 14:24:14+0200 [-] Starting factory <HTTPClientFactory: http://services.buildandshoot.com/getip>
2013-04-13 14:24:14+0200 [-] Started server...
2013-04-13 14:24:14+0200 [-] Master connection established.
2013-04-13 14:24:15+0200 [HTTPPageGetter,client] Server identifier is aos://3679621455:32887
2013-04-13 14:24:15+0200 [HTTPPageGetter,client] Stopping factory <HTTPClientFactory: http://services.buildandshoot.com/getip>
2013-04-13 14:24:17+0200 [HTTPPageGetter,client] Stopping factory <HTTPClientFactory: http://www.blacklist.spadille.net/subsc ... ormat=json>

Thank you.
Same :/ also you need to make other topic about this problem
thepolm3
Scripter
Scripter
Posts: 424
Joined: Sat Feb 16, 2013 10:49 pm


I think the way I solved that was to go into config, and set ban_subscribe{ "enabled":false ,
[RUS] Vlad01
League Participant
League Participant
Posts: 1610
Joined: Sun Dec 16, 2012 7:37 am


Code: Select all
2013-04-29 21:53:11+0400 [-] Log opened.
2013-04-29 21:53:11+0400 [-] Generating map 'classicgen #2085380326'...
2013-04-29 21:53:16+0400 [-] Map loaded successfully.
2013-04-29 21:53:16+0400 [-] Starting factory <HTTPClientFactory: http://service
s.buildandshoot.com/getip>
2013-04-29 21:53:16+0400 [-] Started server...
2013-04-29 21:53:16+0400 [-] Master connection established.
2013-04-29 21:53:16+0400 [HTTPPageGetter,client] Server identifier is aos://3861
970029:32887
2013-04-29 21:53:16+0400 [HTTPPageGetter,client] Stopping factory <HTTPClientFac
tory: http://services.buildandshoot.com/getip>
and again nobody can't join my server :/
thepolm3
Scripter
Scripter
Posts: 424
Joined: Sat Feb 16, 2013 10:49 pm


remember to port forward
[RUS] Vlad01
League Participant
League Participant
Posts: 1610
Joined: Sun Dec 16, 2012 7:37 am


I did it over 9000 times.
What I doing wrong?
Image
thepolm3
Scripter
Scripter
Posts: 424
Joined: Sat Feb 16, 2013 10:49 pm


three things to try;
  1. Make sure the LAN server IP adress is your ipv4 adress; you can get this by going to the search box in the start menu and typing in "cmd", pressing enter and in the black box type "ipconfig". Under IPV4 you should find the correct ip
  2. Make sure that you set the priority of this for INBOUND SERVICES to the top, and set it to allow always.
  3. Make sure that your network router can handel pyspades
Also could you please detail more information: for example, does your server come up on bns, just you can't connect?
If you want to test that your server is working you can join [url=aos://16777343]localhost[/url]
[RUS] Vlad01
League Participant
League Participant
Posts: 1610
Joined: Sun Dec 16, 2012 7:37 am


Make sure the LAN server IP adress is your ipv4 adress; you can get this by going to the search box in the start menu and typing in "cmd", pressing enter and in the black box type "ipconfig". Under IPV4 you should find the correct ip
Ipv4 is right.
Make sure that you set the priority of this for INBOUND SERVICES to the top, and set it to allow always.
I did it.
Make sure that your network router can handel pyspades
ehm.. what is handel?
does your server come up on bns, just you can't connect?
yes.
thepolm3
Scripter
Scripter
Posts: 424
Joined: Sat Feb 16, 2013 10:49 pm


out of interest, why is your ipv4 192.168.1.2? shouldn't it be 0?
[RUS] Vlad01
League Participant
League Participant
Posts: 1610
Joined: Sun Dec 16, 2012 7:37 am


thepolm3
Scripter
Scripter
Posts: 424
Joined: Sat Feb 16, 2013 10:49 pm


try with a zero
[RUS] Vlad01
League Participant
League Participant
Posts: 1610
Joined: Sun Dec 16, 2012 7:37 am


not work :/
thepolm3
Scripter
Scripter
Posts: 424
Joined: Sat Feb 16, 2013 10:49 pm


what is your router make?
[RUS] Vlad01
League Participant
League Participant
Posts: 1610
Joined: Sun Dec 16, 2012 7:37 am


Dlink DSL-2695U
Spoiler:
I think our duscuss will be veeeeery long
65 posts Page 2 of 5
Return to “Servers”

Who is online

Users browsing this forum: No registered users and 1 guest